
 

 

 

 

 

 

 

 

 

 

 



 

YGGIO POWER BI CUSTOM CONNECTOR 

 

Introduction  
The Yggio Power Bi Custom Connector enables the user in a fast and easy way to get data directly from 

an Yggio account into Power BI desktop for advanced analysis. Creating reports likes the following ones 

will just take minutes after some training.  

 

 

Figure 1 Utilization of assets over hour of day 

 

Figure 2 Asset tracking 
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Figure 3 Energy consumption vs outdoor temperature 

 

 

Figure 4 Energy efficiency KPI measurements 

 

Then after exporting the reports to Power BI cloud and installing a Power BI Enterprise gateway with 

access to the Yggio connector they can also be automatically refreshed and shared. However, it is no 

requirement to use Power BI cloud, only using Power BI desktop works well. 
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1. Get started 
 

1.1.  Installation  
To be able to proceed with the installation one must use a Windows (Power BI not supported on 

Mac or Linux) computer and be local administrator on the computer or if IT has set a policy to allow 

the needed components to get installed by users. 

1. Download and install Power BI Desktop directly from: https://docs.microsoft.com/en-

us/power-bi/fundamentals/desktop-get-the-desktop 

 

2. Download the Yggio Power BI Custom Connector ZIP file directly from Yggio Docs/Power BI 

(or other place if instructed by IT) and extract the two files YggioConnector.pqx and 

Yggio_regkey.reg. 

 

a. Place YggioConnector.pqx in the folder (if the folder does not exist create it, it’s 

important to use exactly the correct spelling):  

[Documents] > Power BI Desktop > Custom Connectors 

In a computer with English language setting the folder will be: 

 

b. Double click on the Yggio_regkey.reg and accept that it modifies the computer. This 

will install the Sensative Certificate thumbprint in the computers registry and allow 

Power BI to use the Yggio custom connector without changing Power BI’s security 

settings.  

 

In case the thumbprint is not installed in the registry Power BI will complain that it 

cannot validate the Yggio connector and if user still wants to use it the security 

settings must be lowered to allow 3rd party custom connectors. This can be done 

from the Power BI menu “File > Options and Settings > Global > Security > Data 

Extensions > (Not recommended) Allow any extension load without validation or 

warning”. 

 
1.2. Limitations 
This documentation is focused on the functionality provided by the Yggio Power BI Custom 

Connector. It does not, except for a few hints, contains any description of general Power BI 

documentation which is available on: https://docs.microsoft.com/en-us/power-bi/   

https://docs.microsoft.com/en-us/power-bi/fundamentals/desktop-get-the-desktop
https://docs.microsoft.com/en-us/power-bi/fundamentals/desktop-get-the-desktop
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2. Overview of functionality 
1.3. Fundamentals 
The connector enables three different ways to connect to Yggio and get the data. These three 

different ways provide different levels of freedoms about what amount of IoT nodes and what data 

fields that can be used to select what data to extract: 

1) Navigator: The Power BI Navigator by selecting “Get Data” and search for “Yggio” and then 

connect to an Yggio server. This gives most constraints in what data to retrieve from time 

series but is also the most ease-of-use UX to get started.  

a. For time series charts it is limited to 8 nodes * 4 time series fields that are selected 

from a list of pre-defined fields or manually entered. 

b. The Navigator works well for most use cases when one needs to retrieve data. 

 

2) Formula bar: Use “Get Data” > “Blank query”, write “=Yggio” and then from the drop-down 

box select what Yggio function to use to extract data. This will open a 2 or 3-step guide to 

retrieve data which removes some of the limitations in the Navigator interface.  

a. For charts it is limited to 8 nodes * 4 time series fields where the 3 first time series 

fields are retrieved from the selected nodes and the 4th one is a list of pre-defined 

fields to increase flexibility. 

b. If working with devices where the pre-defined list of time series fields in the 

navigator UI is not providing the expected result using the formula bar probably will.  

 

3) Free query in formula bar: Use “Get Data” > “Blank query”, write “=Yggio” and then directly 

write the full queries in the formula bar. This enables us to extract data from more than 8 

nodes* 4 time series fields in one query by using lists, i.e., all constrains are removed and 

queries can be made that retrieves a lot of data. The drawback is one must know the syntax 

of the queries, the names of the IoT nodes, available options, and eventual fields one wants 

to retrieve. The syntax is well documented when using the Yggio queries inside Power BI. 

There are two reason to use this mode: 

1.  If one wants to retrieve time series data from more than 8 nodes. 

2.  If one wants to use PowerQuery M-language to retrieve complex data sets from 

Yggio.   

 

An easier way to get used to directly write the full queries in the formula bar or in 

PowerQuery is to start with creating a query with the navigator or use the step-by-step 

approach in the formula bar and then modify the resulting query to match the desired 

result.  

 

 

Figure 5 Query modified directly in Formula bar 
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For very advanced users it is feasible to use the Yggio queries directly from inside Power BI 

advanced editor that use PowerQuery language and create complex queries that aggregate 

data from different data sources.   

 

 

1.4. Features 
The following queries are implemented in the connector: 

 

          Figure 6 Available features 

 

• Chart: Retrieve a cube of general time series data for X nodes * Y fields * Z time. Option to 

add extra statistical columns and use value functions (mean, max, min, first, last, count, sum 

and difference) on the time series data to enable fast and easy creation of advanced charts 

or reports, for example billing reports. 

 

 

Figure 7 Data set loaded by Yggio Chart query 
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• ChartEnergy: Retrieve time series data focused on energy efficiency KPI calculation for a 

building based on energy consumption, outdoor temperature, average indoor temperature 

and building area. 

 

• ChartFields: Retrieve available time series fields for selected nodes.    

 

• Device Models: Retrieve available device decoders or “translators” in Yggio terminology. The 

reason it is called translators in Yggio is that it usually includes normalization of data format 

to FIWARE standard instead of just decoding.  

 

• IotNode: Retrieve current data of several IoT nodes formatted in columns to make it easy to 

compare them. 

 

• IotNodes: Retrieve current data of several IoT nodes formatted in rows to increase visibility 

of available data. 

 

• Main: Open the navigator main menu in a table format. Normally not used from formula 

bar. 

 

• Overview: Retrieve an overview of available devices in an account and when they reported.   

 

1.5. Connecting to Yggio 
After selecting “Get Data” or directly starting an Yggio query from the formula bar the following 

dialogue will show up. Choose the Yggio connector.  

 

In the next dialogue box enter the URL to the required Yggio server. 
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Next step is to enter credentials to log in to the server. Enter either your username and password or 

add an API key token. Once this is entered it will get stored in Power BI credential list and will 

automatically be re-used next time you want to connect to the same Yggio server. Yggio API keys will 

expire after a while so if using them one will need to update them from time to time. To be able to 

log in to another account the servers stored credentials must be cleared from Power BI > File > 

Options & Settings > Data Sources. 

 

To make it easy to connect to different Yggio servers and use different Yggio accounts the connector 

uses a pre-defined list of Yggio servers with short names and allows a user defined “tag” to identify 

what credentials to use.  

For example, server “BY” equals https://beta.yggio.net and by using server URL “BY+demo” Power 

BI will store the credentials under the data source path “BY+demo”. This enables, for example, 

“BY+test” to be used as a different data source path to log into another account on the same server. 

Short names for some Yggio servers for reference are: 

• PY = https://public.yggio.net 

• EU = https://yggio.eu 

• BY = https://beta.yggio.net 

• Y3B = https://yggio3-beta.sensative.net  

• YG = https://ygg.io   

 

https://beta.yggio.net.and/
https://public.yggio.net/
https://yggio.eu/
https://beta.yggio.net/
https://yggio3-beta.sensative.net/
https://ygg.io/
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The server’s short name plus the user defined tags to identify data source paths enables a user that 

has knowledge of several different Yggio accounts on an Yggio server, like an appointed data 

scientist and report professional, to quickly switch between accounts and retrieve relevant data to 

make reports and analysis. 

If you get an error message when Power BI tries to get data from Yggio, the URL to the server that 

was entered cannot be found. In that case, please enter a valid server URL or short name.  

 

Figure 8 Yggio server not found 

 

1.6. Ease of use 
The Yggio Power BI connector is forgiving in its syntax evaluation that it will try to interpret what the 

user wants and retrieve the corresponding data. It is not needed to use exact matching names, for 

example using “Temp” will retrieve first available time series field that converted to lower case 

starts with the 4 characters “temp”. Similar forgiveness is available in other places like using the 

time period “2 m” to retrieve the last 2 months of data.  

Inside Power BI the full syntax and what options are available and documented in detail so even 

writing Yggio queries inside the advanced editor will become relatively easy. 

 

Figure 9 Yggio Chart query documentation inside Power BI. If type states “any” it is either a “list” or “text” that get accepted. 

 

1.7. Multi language support 
The connector is multi-lingual and will try to follow the language used in the Power BI installation on 

the computer. Currently it supports English and Swedish language. 

 



 

YGGIO POWER BI CUSTOM CONNECTOR 

3. Use the connector to extract data 
3.1. Navigator interface and parameters 

 

In the Power BI click “Get Data”, in the pop-up windows search for Yggio. 

 

Figure 10 Get Data from Yggio 

After selecting “Connect”, enter the credentials in the Yggio Connector Navigator UI that gets 

displayed. Select the desired query and follow the available options in the UI.  

Charts  

 

Figure 11 The Yggio connector's Navigator UI 
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Per default to support the user in selecting the right data the preview window in the bottom 

right will populate with available IoT nodes and available time series fields after clicking “Apply”. 

It is very helpful to check that one gets the required data before loading it into Power BI. 

 

Figure 12 Some IoT nodes selected and then "Apply" was clicked to get available time series field in the preview window. 

In the query Chart there are some optional parameters that can be set that are very important 

to correctly set to retrieve the expected data. These are: 

• Time period: Defines the time period of data to extract.  

 

• Resolution: Defines resolution of the data to achieve. The amount if data that can be 

retrieved is currently limited by Yggio to 1000 data points per time series field.  

 

o Resolutions of every hour, every day, every week, every month and every 

quarter do exactly what they say and get one data point per time series 

corresponding to the selected resolution. 

o Full resolution: Will take every data point. If high frequency reporting node or 

long time period the 1000 data point limit will limit the time period over which 

one gets data.  
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o High resolution: Will after a certain minimum distance between the data points 

are exceeded, if available, try to retrieve the maximum 1000 data points for the 

given time period. 

o Low resolution: Compared with high resolution has longer minimum distance 

between data points and once that is exceeded, if available, try to retrieve the 

maximum 1000 data points for the given time period. 

 

• Enable calculation of utilization by via extra date columns: This feature adds extra 

columns that group the retrieved data in hour of day, day of week, week no, etc. This 

simplifies the complexity of making reports based on grouped data significantly.  

 

• Value Function: Determines what calculation to apply between data points given by the 

resolution. Available calculations over data points in the given resolution: 

 

o Mean: Calculate the average value. 

o Min: Returns the minimum value. 

o Max: Returns the maximum value. 

o First: Returns the first value. 

o Last: Returns the last value. 

o Count: Count the number of data points. 

o Sum: Summarize the value of all the data points. 

o Difference: Calculate the difference between the value in the last data point and 

the first data point. 

 

 

  

Figure 13 Available optional parameters in Chart query 
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To create a billing metering report, or in Swedish an “IMD – Individuell mätning och debitering” 

report it is recommended to use the following settings: 

• Time period: Last 3 months. 

• Resolution: Every day 

• Extra date columns: True 

• Value function: Difference 

Then one just summarize the delta values per month through Power BI’s standard transform 

and report functions.  

 

Chart Energy Efficiency 

Most advanced feature is the Chart Energy Efficiency that will calculate an energy efficiency KPI 

based on the following formula: 

• Energy used per time unit / (Area x (1+Abs(avg. indoor – outdoor temp)) 

 

Figure 14 Calculate a buildings energy efficiency just by measuring a few parameters 
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Figure 15 Energy efficiency (dark blue) for a building grouped per week during a year 

 

An example of a resulting chart after using an energy efficiency query is available in the above 

image grouped per week. Then if one had changed windows or exchanged to a more efficient 

heating system or take some other action to improve the building the dark blue bars for the 

energy efficiency KPI should become lower. 
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Figure 16 Available pre-defined time series fields. Grouped per area of use case. Chart query is marked and ready to load. 

 

The data will get loaded into Power BI for analysis and creating reports after one marked the 

checkbox next to a query and clicked “Load”. 
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3.2.  The formula bar 
The formula bar is reached from the Power BI UI by clicking 

the small arrow down just below “Get Data” and then select 

“Blank query”. After doing that a new Power Query editor 

window will open and the cursor will be placed in the 

formula bar. 

Start by typing “=Yggio” and the following drop down will get 

visible. 

 

Now one can just select one the queries and then push 

return and the formula bar UI, documentation and the full 

syntax for the selected query will get visible. The different 

queries have different syntax and different required 

parameters but are structured in the same style so one will 

get used to them pretty fast. 

The query called Yggio.Main is the Navigator UI specification and there is no purpose to use it 

directly from the formula bar.  

The first parameters in all queries are the Yggio DiMS server. In some queries one can enter more 

parameters into the first step in the UI but is always ok to just enter the desired server plus 

credential tag and then click invoke.   

 

 

Figure 17 Enter Yggio DiMS with or without a credential tag. Like "BY+mydemo". After clicking “Invoke” if the tag is new the 
username and password dialogue will pop-up. 
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Figure 18 The command to list available device model decoders (translators) available in an Yggio server. The documentation is 
extensive and show exact syntax of each query. 

 

After clicking invoke and enter the credentials Power BI will log in to the Yggio account and new UI 

to fill remaining parameters will get visible with all available nodes pre-populated into the 

dropdown boxes to select node names.  
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Figure 19 UI to retrieve one or several IoT nodes for comparison.  

By entering a list of devices in "Names" a lot of devices can get retrieved. 

 

  

Figure 20 Step 2 in the UI to select what IoT-nodes to compare. 
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In 2nd step depending on query selected one might choose to expand nested JSON structures in 

Yggio data like the raw data and the Context Map (MetaData). After clicking “invoke” one more time 

the data will get loaded into the Power Query editor and one might do further transformations of 

the data set before selecting “Close and apply” and start creating a report. 

 

Figure 21 The resulting data set of the query loaded into the Power Query editor. 

The same principle applies for all the other available queries. The big benefit with using the formula 

bar and its UI to extract data vs the Navigator is that when using the query Yggio.Chart or 

Yggio.ChartEnergy the available time series fields per node name get pre-populated for the first 3 

out of 8 nodes. The 4th field is still the pre-defined time series fields to increase flexibility of what 

data to retrieve for the last 5 nodes. 

                     

Figure 22 After selecting nodes in chart available times series field per nodes will get pre-populated after clicking "Invoke" 
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3.3. Directly enter full query in formula bar 
Except automating the Yggio Power Connector from PowerQuery the main reason to enter the full 

query directly in the formula bar is to avoid limitations in number of node names and time series 

fields that can be retrieved. 

The parameters to enter node names and fields names supports list of parameters 

{“par1”, ”par2”, ”par3”, …} that enables one to go beyond the limitations imposed by the UI. Power 

BI is providing some syntax support when writing the parameters which helps out a lot to get it 

right.  

 

 

Figure 23 Writing full query directly in formula bar that cannot be done through the UI since retrieves 9 different time series 
fields. Requires one know what node names and time series fields to retrieve. 

 

Figure 24 Result of full query above. Since the connector is "forgiving" even if one do some typo one will get some result. 

 

4. Some Power BI hints and sample graphical reports 
Once a data set has been retrieved it is time to create the report. If still in the Power Query editor click 

top left corner “Close and Apply” and the full queries will get loaded into the Power BI data set, then 

click on to the report editor to the top left. 
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Figure 25 Start the report editor by clicking on the graph icon on the top left. 

  

The most important thing to do at first is to change the data type of the datetime column from 

“datetime” to “time”. If not doing this Power BI will try to group all the data and most graph widgets will 

not work as they should. 

                 

 

                  

Figure 26 Change the data type of the datetime column 
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The recommendation then is to start with basic chart widgets like Line chart, Column chart and Pie chart 

and start experimenting by drag and drop time and data fields to their respective corresponding fields. 

On each widget one can usually select if one should summarize the values that ends up same group, do 

average or some other calculation on them. What to choose totally depends on what one is interested 

into visualize. 

 

 

Figure 27 How to make an energy efficiency KPI graph 

 

 

Figure 28 How to make a chart that compare indoor temps, average indoor temps vs outdoor temp by using Yggio.ChartEnergy 
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Figure 29 How to make an IoT node status over view report with Yggio.IoTnodes query 

 

 

Figure 30 How to make distribution of assets od day of year and hour of day (to get left graph just replace "Day of year" with 
"Hour of day" value) 
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Figure 31 Another example of distribution of assets. These are Strips Presence that is not just counting up and instead turn 
"occupancy" on and off so no need to use delta calculation and instead just "Summary" calculation directly on the values. 

 

 

Figure 32 By using a 3rd party downloadable widget called MapBox and populate it with GPS data heat maps can be created. 
Other widgets support movement tracking of assets. 

 


